Tiedote ylläpidolta:

Elektroniikkafoorumi sulkeutuu tietoturva ongelmien takia.
Käyttäjien tietoja (yv:t, sähköpostiosoite ja salasanan hash) on saattanut vuotaa vääriin käsiin.

Foorumi on asettettu vain luku tilaan. Vanhoja keskusteluja voi lukea palvelinsopimuksen päättymiseen asti.
Tietokannasta on poistettu kaikki salasanat, sähköpostiosoitteet ja yksityisviestit.

Jos haluat saada omat yksityisviestisi, lähetä sähköpostia yllapito@elektroniikkafoorumi.com
samasta sähköpostista mikä oli foorumin tiedoissa niin voin kaivella niitä varmuuskopioista.

Mielenkiintoni foorumin ylläpitoon on viime vuosina ollut vähäistä jo muutenkin joten tähän on hyvä lopettaa.
Kiitokset kaikille käyttäjilla ja pahoittelut mahdollisista ongelmista.

Päivitys: Näyttäisi siltä että mahdollinen vuoto koski vanhaa phpBB2 tietokantaa,
joten helmikuuta 2012 uudemmat tiedot pitäisi olla turvassa.

-Lahha
yllapito@elektroniikkafoorumi.com


[Ratkaistu] Kuinka pitkä voi olla 1-Wiren kaapeli. (CAT-5)

Keskustelua digitaalielektroniikasta

Valvoja: Moderaattorit


Jäsen
Jäsen
Viestit: 134
Liittynyt: La Maalis 17, 2012 14:43
ViestiLähetetty: La Touko 30, 2015 20:29
Kuinkahan pitkän kaapelin voi vetää Arduino One:n datapinniin ja (One-Wire) DS18B20-lämpömittarin välille ?

Kaapeli on CAT-5-verkkokaapelia. Tarve olisi n. 20-30 metriä. Vedän anturin 3:lla johdolla l. 1-data, 1-maa, 1-5V.

Spekseissä en löytänyt metrimäärää, enkä oikein osannut googlettaakaan.
Viimeksi muokannut peran päivämäärä Ke Kesä 03, 2015 16:15, muokattu yhteensä 1 kerran

Jäsen
Jäsen
Viestit: 134
Liittynyt: La Maalis 17, 2012 14:43
ViestiLähetetty: La Touko 30, 2015 20:48
Jostain luin, että signaali riittää 150 jalkaan, eli n. 45 metriin, joten ilmeisesti ei ole odotettavissa ongelmia.

Vanhempi jäsen
Vanhempi jäsen
Viestit: 595
Liittynyt: La Marras 12, 2011 14:56
ViestiLähetetty: La Touko 30, 2015 22:43
Kolmella johdolla menee joskus vallan pikästikin. Parasiittisyötöllä tulee ongelmia helpommin, siinä 30m on tiukassa.

Jäsen
Jäsen
Viestit: 134
Liittynyt: La Maalis 17, 2012 14:43
ViestiLähetetty: Su Touko 31, 2015 6:16
Jussi kirjoitti:Kolmella johdolla menee joskus vallan pikästikin. Parasiittisyötöllä tulee ongelmia helpommin, siinä 30m on tiukassa.


Kumpaan päähän kannattaalaittaa 4k7Ω:n vastus: juureen vai lähelle anturia ?
(Juureen on helpompi.)

Vanhempi jäsen
Vanhempi jäsen
Viestit: 595
Liittynyt: La Marras 12, 2011 14:56
ViestiLähetetty: Su Touko 31, 2015 11:06
peran kirjoitti:
Jussi kirjoitti:Kolmella johdolla menee joskus vallan pikästikin. Parasiittisyötöllä tulee ongelmia helpommin, siinä 30m on tiukassa.


Kumpaan päähän kannattaalaittaa 4k7Ω:n vastus: juureen vai lähelle anturia ?
(Juureen on helpompi.)


En ole edes laittanut. Voi ehkä kokeilla ensin ilman, jos ei Arduino sitä vaadi sinne.

Jäsen
Jäsen
Viestit: 134
Liittynyt: La Maalis 17, 2012 14:43
ViestiLähetetty: Su Touko 31, 2015 11:41
Jussi kirjoitti:En ole edes laittanut. Voi ehkä kokeilla ensin ilman, jos ei Arduino sitä vaadi sinne.


Pitääpäs kokeilla ilman vastusta, vaikka speksien mukaan sellaista suositellaankin. Kiitos.

Jäsen
Jäsen
Viestit: 134
Liittynyt: La Maalis 17, 2012 14:43
ViestiLähetetty: Ke Kesä 03, 2015 16:14
peran kirjoitti:
Jussi kirjoitti:En ole edes laittanut. Voi ehkä kokeilla ensin ilman, jos ei Arduino sitä vaadi sinne.


Pitääpäs kokeilla ilman vastusta, vaikka speksien mukaan sellaista suositellaankin. Kiitos.


Joo-o. Ei toiminut ilman vastusta, mutta vastuksen kanssa toimi, joten tämä Case on ratkaistu. Vastus on juuressa.

Kiitoksia.

Jäsen
Jäsen
Viestit: 134
Liittynyt: La Maalis 17, 2012 14:43
ViestiLähetetty: To Kesä 23, 2016 19:49
Nolo juttu, kun en saanut toimimaan "pitkällä johdolla", en kehdannut tänne tulla itkemään.

Ei siis toiminut suoraan...

No, luulin sen johtuvan pitkän johdon aiheuttamasta häiriöistä.
Ajattelin, että tilaan kiinasta MAX232-kortin. Nyt vihdoin tuli ne. No, sitten ei toiminut enää lyhyelläkään johdolla.

Ajattelin, että olin hajottanut Arduino Nanon pinnin, jossa anturi oli kiinni.

Rupesin testaamaan pinniä. Maa->Pinni toimi digitalwritellä. Sitten kokeilin +5V->pinni. No yllätyksekseni se ei toiminutkaan. Ajattelin, että +5V:n ulostulo oli hajonnut.

No, jostakin syystä mittasin piirilevyni, ja kas piirilevyssäni puuttui yhteys +5V - pinniin.

Eilen sain selville kyseisen bugin, ja korjasin sen myös eilen. Nyt toimii mittari, mutta oppimisen puolellehan tämä meni.

Loppujen lopuksi sain siistin sötöksen anturiin ja sieltä arduinoon.

Hyvää Jussin päivän aattoa kaikille.

Paluu Digitaalielektroniikka

Paikallaolijat

Käyttäjiä lukemassa tätä aluetta: Ei rekisteröityneitä käyttäjiä ja 1 vierailijaa

cron